Powerbot+ for KofC

by Barbarossa

Click here to visit the PB+ Facebook Page

Click here to download and install the latest version of PowerBot+

Compatible with Firefox Version 31 or below, Palemoon, Cometbird or similar, Google Chrome, Apple Safari, etc.
Note you will need Greasemonkey (1.15 or below), Scriptish or Tampermonkey installed on your browser!

Click here to install Greasemonkey 3.30rc1 fork for Palemoon (direct link, it will ask you to confirm install is allowed. Say Yes!)
Click here to install Greasemonkey version 1.15.1-signed (direct link, it will ask you to confirm install is allowed. Say Yes!)



Click here to donate in GBP     Click here to donate in EUR     Click here to donate in CAD